KPT SceneBuilder
Tutorial

Welcome to the KPT® SceneBuilder tutorial. This
tutorial introduces you to all the major features
and functions in KPT SceneBuilder—teaching
you the techniques you need to know to create
3D illustrations.

Each section is self-contained so that you can start
the tutorial at any point. If you're a beginner, we
recommend that you begin with Lesson 1.

The tutorial uses various files which you can find
on your KPT 6 CD-ROM in the Tutorials:
KPT SceneBuilder folder.



Lesson 1: Getting
Started

In this lesson, you'll launch KPT
SceneBuilder, load a simple object, and learn
how to manipulate it in KPT SceneBuilder’s
workspace.

Loading an Object

You'll use a small 300 by 300 pixel document
as the base image for launching KPT
SceneBuilder.You’ll then load an existing

object and view it in different preview modes.

To load an object:

1 Launch the host application—either
Adobe® Photoshop® or a Photoshop-
compliant host, such as MetaCreations™
Painter™,

2 Create a new 300 by 300 pixel RGB
document with a white background.

3 Choose Filter menu> KPT6> KPT
SceneBuilder.

4 Click and hold on the File button—
choose Open from the menu.

The Open dialog appears.

5 Use the dialog controls to select
Torus.ptc, located in the Tutorials: KPT
SceneBuilder folder on your KPT 6
CD-ROM.
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A blue torus appears in the middle of the KPT
SceneBuilder workspace. It is displayed using
the default Preview mode—Wireframe.
Throughout this tutorial, you’ll work in
Gouraud shaded mode.

To change the Preview mode:

*  Click the Gouraud shaded icon on the
left side of the Scene window.

a

If this is your first time using KPT
SceneBuilder, the default mode is Edit 2D. If
you've already worked with KPT
SceneBuilder, make sure that Edit 2D mode is
still active.

To select Edit 2D mode:

*  Click the Edit 2D tab at the top of the
workspace.

The KPT SceneBuilder workspace should
appear as follows.




Using the Ghost Menu

You can access many of the commands you’ll
use in the following sections through the
Ghost menu.

The Ghost menu.

The key benefits of using the Ghost menu are:

*  You don’t have to move the mouse to the
toolbar—the menu pops up under your
MOuSse.

e You don't have to remember keyboard
commands.

e The Ghost menu recalls your last action.
The next time you activate it, the
command you used last time is directly
under your cursor. To activate the same
command again, just release the mouse
button.

To access the Ghost menu:

*  Windows: Right click in the Scene
window.

e Macintosh: Control+Click in the Scene
window.

Manipulating the Object

Now that you've loaded the object, you can
move, rotate, and resize it in the workspace.

To move the object:

1 Click on the torus to select it.

2 Drag it to a desired location.
To rotate the object:

1 Click on the torus to select it.
2 Do one of the following:

¢ Choose Rotate from the Ghost
Menu.

e Click the Rotate Objects tool in the
Object panel.

3 Drag in the Scene window to rotate the
object to a new orientation.

To rotate the object around one axis:

1 Make sure the object is selected.

2 Choose Rotate X,Y,or Z from the Ghost
menu.

3 Drag the mouse horizontally.
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To scale the object:

1 Make sure the object is selected.

2 Do one of the following:

¢ Choose Scale from the Ghost menu.

e Click the Scale tool in the Object

panel.

3 Drag the mouse horizontally to change
the object’s size.

To scale the object along one axis:

1 Make sure the object is selected.

2 Choose Scale X,Y, or Z from the Ghost
Menu.

Move, scale, and rotate the torus several times

to get used to using the commands and tools.

The rotated and scaled torus.
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If the torus gets too distorted, go back to its
previous state using the Undo and Redo
commands.

To undo the last object manipulation:

*  Click on the Edit button and choose
Undo, or

*  Press Command/Ctrl+Z.

To redo the last undone object
manipulation:

e Click on the Edit button and choose
Redo, or

*  Press Command/Ctrl+Y.

Shading the Object

A shader is the mechanism that allows you to
apply surface properties to an object. An
object’s shader determines whether it is shiny
or dull, rough or smooth, transparent or
opaque.

Each shader has multiple channels—each
controls a specific property of the object’s
surface. By adjusting the various channels, you
can completely change how an object looks.

Let’s start by changing the color of the torus
to purple.



To change the object’s color:

1 Click on the Color tab in the Shader
panel.

.

The color channel options appear in the
right side of the Shader panel.

Click the Use color option.
Click on the color swatch.

A color window appears, containing a
color spectrum.

4 Release the mouse button when the
mouse is over the purple area of the color
spectrum.

The torus is now purple, but lacks a shiny and
realistic surface. In the real world, objects
show highlights when they are illuminated.
These bright spots are reflections of light
sources onto the material.

The material of an object determines the
quality of its highlights. For example, plastic
surfaces have large, dimmed highlights, while
metallic objects have small, bright highlights.
Other materials—Ilike stone and concrete—do
not produce highlights.

To change the object’s highlights:

1 Click on the Highlight tab in the Shader
panel.

The highlight channel options appear in
the right side of the Shader panel.

2 Click on the color swatch.

A color window appears, containing a
color spectrum.

3 Release the mouse button when the
mouse is over the white area of the color
spectrum.

4 Set the Shininess slider to 5.

The object now has highlights.

The purple torus with highlights.

Rotate the torus to see how the highlights
interact with the scene lighting. Refer to
“Manipulating the Object” on page 3 for
more information about rotating objects.
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Rendering the Obiject Lesson 2: Working
with Cameras and

You are now ready to render the object and

return to the host application. Texture
To render the object: To start this lesson:
*  Click the OK button. 1 Create a new 400 by 300 pixel RGB

document in the host application.
In a few seconds, the purple torus appears in )
the host application document. Zoom into Launch KPT SceneBuilder.
the image to see the subtle light interactions 3 Open Cube.ptc, located in the Tutorials:
and high quality antialiasing at the edges of the KPT SceneBuilder folder on your
torus. KPT 6 CD-ROM.

Using Edit 3D Mode

In the previous lesson, you learned how to
manipulate the object in a 2D workspace.
Now, you'll learn about working in KPT
SceneBuilder’s 3D workspace.

To edit in 3D:

The rendered image.

*  Click the Edit 3D tab at the top of the
workspace.
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In Edit 3D mode, the object appears in
three-dimensional space—as if you’re looking
at it through the viewfinder of a real camera.

An object in the three-dimensional workspace.

When you work in Edit 3D mode, you can
change your view of the object in three-
dimensional space by repositioning the scene’s
camera.The Camera panel contains four tools
for adjusting the camera position:

e Zoom
e Pan
* Dolly

e Set camera Focal

The Camera tools.

Let’s start by rotating the camera around the
object using the Dolly tool.

To use the Dolly tool:

1 Do one of the following:

e Click the Dolly tool in the Camera
panel.

e Choose Dolly from the Ghost Menu.

2 Drag in the Scene window to rotate the
view.

Notice that the cursor reflects the active
tool.

Now try changing your view of the object
using the other camera tools.

You can also access preset camera positions
from the alternate Ghost menu.

The alternate Ghost menu.

To access the alternate Ghost menu:

1 Hold down the Option/Alt key.
2 Do one of the following:

¢ Windows: Right click in the Scene
window.

¢ Macintosh: Ctrl+Click in the Scene
window.
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Adding a Texture Map

KPT SceneBuilder allows you to wrap a 2D
image around the surface of an object. This
image is called a texture map.

Used effectively, a texture map can lend
unparalleled realism to an object. In fact,
complex objects are nearly impossible to
simulate through other means.

To add a texture map to the object: The textured cube.

1 Click on the Color tab in the Shader Textured mode just shows you a preview of
panel.

the textured object.You do not have to exit
KPT SceneBuilder to view the final-quality
image—you can render the object directly in
'l the Scene window.

To view the final-quality texture:

) ) 1 Click the Render Image icon.
The color channel options appear in the

right side of the Shader panel.

2 Click the Use texture option.
While the image is rendering, you can
abort the operation by pressing the Esc
3 Use the dialog controls to select key or Command-+(.).

DieMap.jpg, located in the Tutorials:

KPT SceneBuilder folder on your

KPT 6 CD-ROM.

4 Click the Textured icon on the left side
of the Scene window to view the texture.

0

The file selector dialog appears.

il
“;‘

The rendered cube.
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Adding a Bump Map

Rough surfaces are extremely difficult to
model. For example, imagine the irregularities
of an orange skin—it is impossible to model
each irregularity by hand.

KPT SceneBuilder simulates the variations on
the surface of an object using the bump
channel.

Bump intensity ;

Bump T exture:

The bump channel.

By loading an image into the bump channel,
you can add irregularities to a smooth surface.
To simulate bumps, the bump channel
changes the variation in intensity between
adjacent pixels. Only the relative change
between adjacent pixels is important—the
color information in the loaded image (called
a bump map) does not affect the bump quality.

To add a bump map to the object:

1 Click on the Bump tab in the Shader
panel.

The bump channel options appear in the
right side of the Shader panel.

2 Click the disk icon on the left side of the
bump map swatch.

The file selector dialog appears.

3 Use the dialog controls to select
DieBumpMap.jpg, located in the
Tutorials: KPT SceneBuilder folder
on your KPT 6 CD-ROM.

4 Set the Bump Intensity slider to —1.3.

This creates the appearance of little holes
around the black dots on the dice

5 Click the Render Image icon to see the
final-quality result.

Saving Your Work

To save the scene to a new file:

1  Use the camera tools to achieve the
desired view of the object.
Choose File menu> Save As.

Use the dialog controls to enter a new file
name and location.
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Rendering in Photoshop

The following information is specific
Note
to Adobe Photoshop.

When you click OK to render the object, you
exit KPT SceneBuilder and return to
Photoshop. By using a simple keyboard
command, you can re-render the object in the
Photoshop document without launching KPT
SceneBuilder.

To render the object in Photoshop:

1 Create a selection in the Photoshop
document using the Rectangular
Marquee Tool.

2 Press Command/Ctrl+F to re-render the
object.

“‘

s
-

Cubes rendered in Photoshop.
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Lesson 3: Working with
Lights, Reflections, and
Transparency

To start this lesson:

1 Create a new 400 by 300 pixel RGB
document in the host application.

2 Fill the background with a neutral dark
gray.
3 Launch KPT SceneBuilder.

4 Open Dollar.ptc, located in the
Tutorials: KPT SceneBuilder folder
on your KPT 6 CD-ROM.

Lighting the Scene

The appearance of objects in KPT
SceneBuilder is determined by the scene’s
light sources. A good lighting scheme
dramatically increases the readability and the
atmosphere of a rendered scene.

Lighting effects are only visible when

Note

using Flat shaded, Gouraud shaded,
or Textured Preview mode. In this
lesson, use the Gouraud shaded

mode.

The same scene rendered with two different
lighting schemes will produce completely
different results. For example, a lighting
scheme with dark lights produces a dark
image. A lighting scheme with bright lights
washes out subtle effects.



The Light Sources panel lets you adjustupto 5 Drag the highlight on the surface of the
six directional light sources and one ambient light sphere to the center.
light source.

Light Sources

.'{,-,‘_.

6 Continue working with the first four
light sources to achieve the following
settings:

Color Highlight

Light Sources panel. Light1  white
To set up the scene’s light source:
.
1 In the Light Sources panel, click the Light2  peach
leftmost light bulb icon.
The icon changes to a switched off light
bulb.
. . . . . Light3 gray
2 Click the light bulb icon again. The icon
changes to a switched on light bulb,
indicating that the light source is on.
3 Click the color swatch below the light Light4  light blue
bulb icon you just turned on. -
M
A color window appears, containing a 7 Click the Render Image icon to see the
color spectrum. Release the mouse lighting result.
button when the mouse is over the white The surface of the object should look like
area of the color spectrum. dull metal. Next, you’ll add some
reflections.

4 Select the second light source from the
left by clicking on the button beneath the
lights color swatch.
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Adding Reflections and
Transparency

One of KPT SceneBuilder’s key features is the
Interactive Texture Renderer—which renders
the current scene with final-quality reflections
and transparency in real-time.

To use the Interactive Texture Renderer:

1 Click Interactive Texture tab at the top of
the workspace.

2 Click the black image in the center of
window.

A preview of the rendered scene appears.
3 Click dollar object to select it.
Now, you’ll add reflections and transparency

to the dollar to create a realistic, mirror-like
surface.

To add reflections and transparency:

1  Click on the Color tab in the Shader
panel and set the color to black.

2 Click the Reflection tab and set the color
to gold.

3 In the Environment panel—which is
located below the Light Sources panel—
click the disk icon.

Environment
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Select Environm.jpg, located in the
Tutorials: KPT SceneBuilder folder
on your KPT 6 CD-ROM.

The object should look like this:

The environment map you just set up
simulates a 3D environment surrounding
the object. When you render the scene,
light reflects off this environment onto
the surface of the object, creating realistic
reflections.

Click the Transparency tab in the Shader
panel. Set the color to gray and the Index
of refraction slider to 1.

Click OK to render the object.



Lesson 4: Building a
Scene
In this lesson, you'll insert an object into a

scene and duplicate it to create a button for
use on a\Web page.

To start this lesson:
1 Create a new 400 by 300 pixel RGB

document in the host application.

2 Fill the background with a neutral dark
gray.

3 Launch KPT SceneBuilder.

4 Open Button.ptc, located in the

Tutorials: KPT SceneBuilder folder
on your KPT 6 CD-ROM.

5 Select Gouraud shaded preview mode.
To insert and duplicate objects:

1 Choose File menu> Insert.

2 Use the dialog control to select w.ptc,
located in the Tutorials: KPT
SceneBuilder folder on your KPT 6
CD-ROM.

3 Click Open.
The scene should look like this:

SN

Select the “w”.

Choose Edit menu> Duplicate, or
press Command/Ctrl+D, to duplicate the
object.

You won't see two “w’’s because the
duplicate sits directly on top of the
original.

6 Repeat the previous step to duplicate the

W again.

7 Select the top “w” and drag it to the
right.

8  Select the middle “w” and drag it to the
left.

The scene should look like this:

The scene after duplicating the “w”.

When you have multiple objects in a scene, it
is often easier to manipulate them as a group.
A grouped object has a blue bounding box
when you select it, as opposed to stand-alone
objects, whose bounding boxes are white.
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To group and scale the “w’s:

1 Select all three “ws.

2 Choose Edit Menu> Group, or press
Command/Ctrl+G.

3 Scale the grouped object to reduce its
size.

Refer to “Manipulating the Object” on
page 3 for more information about
scaling objects.

4 Position the grouped “w”s so that they
are centered on the button.

5 Press the OK button to render the scene.
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Lesson 5: Working
with Layers

In this lesson, we use Photoshop 5 as

Note

a host application. However, you can
create similar effects in another

host—such as MetaCreations Painter.

KPT SceneBuilder objects are anti-aliased
using the alpha channel, so you can freely
move the objects around, rearrange layers, and
add shadows or glows with Photoshop layer
effects.

To start this lesson:

1 In Photoshop, open Background.jpg,
located in the Tutorials: KPT
SceneBuilder folder on your KPT 6
CD-ROM.

Create a new layer and select it.
Launch KPT SceneBuilder.

4 Open Mars.ptc, located in the Tutorials:
KPT SceneBuilder folder on your
KPT 6 CD-ROM.

A flying source appears in the KPT
SceneBuilder workspace.

5 Click the OK button to render flying
saucer.

KPT SceneBuilder renders the flying saucer in
the transparent layer. The object’s borders
blend perfectly with the background, due to
the anti-aliasing transparency.



To add special effects to the image:

1 In Photoshop, select Layer menu>
Effects> Outer Glow and enter the
following settings:

Effects

[Querow ]
ECI:

The image should look like this:

2 Create a new layer and launch KPT
SceneBuilder.

3 Select the flying saucer, reduce its size,
rotate it, and move it up and to the right.

4 Click OK to render the object.

5 Repeat Step 1 to add a green glow to the
new flying saucer.

6 Repeat Steps 2 through 5 to create a third
flying saucer in a new layer. This time,
position the flying saucer at the top of the
scene.

Your image should look like this:

The layered image.

As you can see, KPT SceneBuilder lets you
create 3D illustrations with unparalleled
simplicity and speed. No other 3D application
lets you change the background and position
of objects, add or remove glows and shadows,
etc., without re-rendering the entire scene.

This is especially true when working with
high resolution images. Sometime, rendering
an image in a 3D application can take hours.
With KPT SceneBuilder, you can re-render a
single object in a layer in a matter of seconds.

T- When working with a large scene,

Ip consider working with a multiple layer
document. This speeds up rendering

time and gives you more freedom to

express your ideas.
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Lesson 6: Creating a
Cartoon

In this lesson, we use Photoshop 5 as

Note

a host application. However, you can
create similar effects in another
host—such as MetaCreations Painter.

To start this lesson:

1 Create a new 800 by 600 pixels RGB
document in Photoshop. The background
must be a pure white.

Launch KPT SceneBuilder.

Open Mouse.ptc, located in the
Tutorials: KPT SceneBuilder folder
on your KPT 6 CD-ROM.

Select the cheese.
5 Adjust the shader settings as follows:
e Color: black
< Highlight: white
e Shininess: 0

6 Drag and drop the shader onto the other
objects in the scene—the mouse and the
eyes of the mouse.

7  Click OK to render the scene.
The image should look like this:
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To create the cartoon in Photoshop:

1 Choose Image menu> Adjust>
Threshold.

2 Set Threshold Level to 230
Click OK.
The image is now black and white.

4 With the Magic Wand, select a black part
of the image.

5 Choose Select menu> Similar.

The black areas of the image are now
selected.

6  Choose Make Work Path in the Paths
palette.

Set Tolerance to 1.0 pixels and click OK.

Deselect the Work Path in the Paths
palette.

9  Clear the document by choosing Select>
All and pressing the Delete key. The
document must be completely white.

10 Select the Work Path in the Paths palette.

11 Click on the “Loads Path As Selection”
button in the Paths palette.

12 Deselect the path.



13 Fill the selection with black using the Fill
command in the Edit menu.

Your cartoon is complete.

The final image.
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